Description:

Translates a parameter from a value on the surface returned by ToNurbsSurface() to the current surface.

Syntax:
public bool GetSurfaceParameterFromNurbsFormParameter(
double nurbsS,
double nurbsT,
out double surfaceS,
out double surfaceT
)
Parameters:
  • nurbsS
  • Type: double
  • The parameter in the S, or sometimes U, direction of the NURBS form surface.
  • nurbsT
  • Type: double
  • The parameter in the T, or sometimes V, direction of the NURBS form surface.
  • surfaceS
  • Type: double
  • S on this surface.
  • surfaceT
  • Type: double
  • T o n this surface.
Returns:
Type: bool
True if the operation succeeded; otherwise, false.
Available since:
6.0

/
/
/
GetSurfaceParameterFromNurbsFormParameter

GetSurfaceParameterFromNurbsFormParameter method

Class:  Rhino.Geometry.Surface

Nothing found