Description:

Tests a surface to see if it is a portion of a torus and returns the torus.

Syntax:
public bool TryGetTorus(
out Torus torus,
double tolerance
)
Parameters:
  • torus
  • Type: Torus
  • On success, the torus parameters are filled in.
  • tolerance
  • Type: double
  • tolerance to use when checking.
Returns:
Type: bool
True if the surface is a portion of a torus.
Available since:
5.0

Description:

Tests a surface to see if it is a portion of a torus within RhinoMath.ZeroTolerance and returns the torus.

Syntax:
public bool TryGetTorus(
out Torus torus
)
Parameters:
  • torus
  • Type: Torus
  • On success, the torus parameters are filled in.
Returns:
Type: bool
True if the surface is a portion of a torus.
Available since:
5.0

TryGetTorus method

Class:  Rhino.Geometry.Surface

Nothing found