menu
RhinoCommon API
search
search
V8
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Tests if a surface parameter value is at a singularity.
Syntax:
public
bool
IsAtSingularity(
double
u
,
double
v
,
bool
exact
)
Parameters:
u
Type:
double
Surface u parameter to test.
v
Type:
double
Surface v parameter to test.
exact
Type:
bool
If true, test if (u,v) is exactly at a singularity. If false, test if close enough to cause numerical problems.
Returns:
Type:
bool
True if surface is singular at (s,t)
Available since:
5.0
home
/
Rhino.Geometry
/
Surface
/
IsAtSingularity
IsAtSingularity method
Class:
Rhino.Geometry.Surface
Nothing found