Description:

Same as Reverse, but if inPlace is set to True this Surface is modified instead of a new copy being created.

Syntax:
public Surface Reverse(
int direction,
bool inPlace
)
Parameters:
  • direction
  • Type: int
  • 0 for first parameter's domain, 1 for second parameter's domain.
Returns:
Type: Surface
If inPlace is False, a new reversed surface on success. If inPlace is true, this surface instance is returned on success.
Available since:
5.8

Description:

Reverses parameterization Domain changes from [a,b] to [-b,-a]

Syntax:
public Surface Reverse(
int direction
)
Parameters:
  • direction
  • Type: int
  • 0 for first parameter's domain, 1 for second parameter's domain.
Returns:
Type: Surface
a new reversed surface on success.
Available since:
5.0

Reverse method

Class:  Rhino.Geometry.Surface

Nothing found