Description:

Smooths a surface by averaging the positions of control points in a specified region.

Syntax:
public Surface Smooth(
double smoothFactor,
bool bXSmooth,
bool bYSmooth,
bool bZSmooth,
bool bFixBoundaries,
SmoothingCoordinateSystem coordinateSystem,
Plane plane
)
Parameters:
  • smoothFactor
  • Type: double
  • The smoothing factor, which controls how much control points move towards the average of the neighboring control points.
  • bXSmooth
  • Type: bool
  • When True control points move in X axis direction.
  • bYSmooth
  • Type: bool
  • When True control points move in Y axis direction.
  • bZSmooth
  • Type: bool
  • When True control points move in Z axis direction.
  • bFixBoundaries
  • Type: bool
  • When True the surface edges don't move.
  • plane
  • Type: Plane
  • If SmoothingCoordinateSystem.CPlane specified, then the construction plane.
Returns:
Type: Surface
The smoothed surface if successful, None otherwise.
Available since:
6.0

Description:

Smooths a surface by averaging the positions of control points in a specified region.

Syntax:
public Surface Smooth(
double smoothFactor,
bool bXSmooth,
bool bYSmooth,
bool bZSmooth,
bool bFixBoundaries,
SmoothingCoordinateSystem coordinateSystem
)
Parameters:
  • smoothFactor
  • Type: double
  • The smoothing factor, which controls how much control points move towards the average of the neighboring control points.
  • bXSmooth
  • Type: bool
  • When True control points move in X axis direction.
  • bYSmooth
  • Type: bool
  • When True control points move in Y axis direction.
  • bZSmooth
  • Type: bool
  • When True control points move in Z axis direction.
  • bFixBoundaries
  • Type: bool
  • When True the surface edges don't move.
Returns:
Type: Surface
The smoothed surface if successful, None otherwise.
Available since:
6.0

Smooth method

Class:  Rhino.Geometry.Surface

Nothing found