Description:

Computes a 3d curve that is the composite of a 2d curve and the surface map.

Syntax:
public Curve Pushup(
Curve curve2d,
double tolerance,
Interval curve2dSubdomain
)
Parameters:
  • curve2d
  • Type: Curve
  • a 2d curve whose image is in the surface's domain.
  • tolerance
  • Type: double
  • the maximum acceptable distance from the returned 3d curve to the image of curve_2d on the surface.
  • curve2dSubdomain
  • Type: Interval
  • The curve interval (a sub-domain of the original curve) to use.
Returns:
Type: Curve
3d curve.
Available since:
5.0

Description:

Computes a 3d curve that is the composite of a 2d curve and the surface map.

Syntax:
public Curve Pushup(
Curve curve2d,
double tolerance
)
Parameters:
  • curve2d
  • Type: Curve
  • a 2d curve whose image is in the surface's domain.
  • tolerance
  • Type: double
  • the maximum acceptable distance from the returned 3d curve to the image of curve_2d on the surface.
Returns:
Type: Curve
3d curve.
Available since:
5.0

Pushup method

Class:  Rhino.Geometry.Surface

Nothing found