Description:

Copies a surface so that all locations at the corners of the copied surface are specified distances from the original surface.

Syntax:
public Surface VariableOffset(
double uMinvMin,
double uMinvMax,
double uMaxvMin,
double uMaxvMax,
double tolerance
)
Parameters:
  • uMinvMin
  • Type: double
  • Offset distance at Domain(0).Min, Domain(1).Min.
  • uMinvMax
  • Type: double
  • Offset distance at Domain(0).Min, Domain(1).Max.
  • uMaxvMin
  • Type: double
  • Offset distance at Domain(0).Max, Domain(1).Min.
  • uMaxvMax
  • Type: double
  • Offset distance at Domain(0).Max, Domain(1).Max.
  • tolerance
  • Type: double
  • The offset tolerance.
Returns:
Type: Surface
The offset surface if successful, None otherwise.
Available since:
6.13

Description:

Copies a surface so that all locations at the corners, and from specified interior locations, of the copied surface are specified distances from the original surface.

Syntax:
public Surface VariableOffset(
double uMinvMin,
double uMinvMax,
double uMaxvMin,
double uMaxvMax,
IEnumerable<Point2d> interiorParameters,
IEnumerable<double> interiorDistances,
double tolerance
)
Parameters:
  • uMinvMin
  • Type: double
  • Offset distance at Domain(0).Min, Domain(1).Min.
  • uMinvMax
  • Type: double
  • Offset distance at Domain(0).Min, Domain(1).Max.
  • uMaxvMin
  • Type: double
  • Offset distance at Domain(0).Max, Domain(1).Min.
  • uMaxvMax
  • Type: double
  • Offset distance at Domain(0).Max, Domain(1).Max.
  • interiorParameters
  • Type: IEnumerable<Point2d>
  • An array of interior UV parameters to offset from.
  • interiorDistances
  • Type: IEnumerable<double>
  • >An array of offset distances at the interior UV parameters.
  • tolerance
  • Type: double
  • The offset tolerance.
Returns:
Type: Surface
The offset surface if successful, None otherwise.
Available since:
6.13

/
/
/
VariableOffset

VariableOffset method

Class:  Rhino.Geometry.Surface

Nothing found