Description:

Rebuilds an existing surface to a given degree and point count.

Syntax:
public NurbsSurface Rebuild(
int uDegree,
int vDegree,
int uPointCount,
int vPointCount
)
Parameters:
  • uDegree
  • Type: int
  • the output surface u degree.
  • vDegree
  • Type: int
  • the output surface u degree.
  • uPointCount
  • Type: int
  • The number of points in the output surface u direction. Must be bigger than uDegree (maximum value is 1000)
  • vPointCount
  • Type: int
  • The number of points in the output surface v direction. Must be bigger than vDegree (maximum value is 1000)
Returns:
new rebuilt surface on success. None on failure.
Available since:
5.0

Rebuild method

Class:  Rhino.Geometry.Surface

Nothing found