Description:

Translates a parameter from the current surface to the parameter space of the surface returned by ToNurbsSurface() .

Syntax:
public bool GetNurbsFormParameterFromSurfaceParameter(
double surfaceS,
double surfaceT,
out double nurbsS,
out double nurbsT
)
Parameters:
  • surfaceS
  • Type: double
  • The parameter in the S, or sometimes U, direction, of this surface.
  • surfaceT
  • Type: double
  • The parameter in the T, or sometimes V, direction of this surface.
  • nurbsS
  • Type: double
  • S on the NURBS form.
  • nurbsT
  • Type: double
  • T on the NURBS form.
Returns:
Type: bool
True if the operation succeeded; otherwise, false.
Available since:
6.0

/
/
/
GetNurbsFormParameterFromSurfaceParameter

GetNurbsFormParameterFromSurfaceParameter method

Class:  Rhino.Geometry.Surface

Nothing found