Description:

Tests a surface to see if it is planar to zero tolerance.

Syntax:
public bool IsPlanar()
Returns:
Type: bool
True if the surface is planar (flat) to within RhinoMath.ZeroTolerance units (1e-12).
Available since:
5.0

Description:

Tests a surface to see if it is planar to a given tolerance.

Syntax:
public bool IsPlanar(
double tolerance
)
Parameters:
  • tolerance
  • Type: double
  • tolerance to use when checking.
Returns:
Type: bool
True if there is a plane such that the maximum distance from the surface to the plane is <= tolerance.
Available since:
5.0

Nothing found