menu
RhinoCommon API
search
search
V8
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Tests a surface for planarity and return the plane.
Syntax:
public
bool
TryGetPlane(
out
Plane
plane
,
double
tolerance
)
Parameters:
plane
Type:
Plane
On success, the plane parameters are filled in.
tolerance
Type:
double
tolerance to use when checking.
Returns:
Type:
bool
True if there is a plane such that the maximum distance from the surface to the plane is <= tolerance.
Available since:
5.0
Description:
Tests a surface for planarity and return the plane.
Syntax:
public
bool
TryGetPlane(
out
Plane
plane
)
Parameters:
plane
Type:
Plane
On success, the plane parameters are filled in.
Returns:
Type:
bool
True if there is a plane such that the maximum distance from the surface to the plane is <= RhinoMath.ZeroTolerance.
Available since:
5.0
home
/
Rhino.Geometry
/
Surface
/
TryGetPlane
TryGetPlane method
Class:
Rhino.Geometry.Surface
Example
Nothing found