Description:

Create tween surfaces that gradually transition between two bounding surfaces using point sampling.

Syntax:
public static Surface[] CreateTweenSurfacesWithSampling(
Surface surface0,
Surface surface1,
int numSurfaces,
int numSamples,
double tolerance
)
Parameters:
  • surface0
  • Type: Surface
  • The first, or starting, surface.
  • surface1
  • Type: Surface
  • The second, or ending, curve.
  • numSurfaces
  • Type: int
  • Number of tween surfaces to create.
  • numSamples
  • Type: int
  • Number of sample points along input surfaces.
  • tolerance
  • Type: double
  • The tolerance. When in doubt, use the document's model absolute tolerance.
Returns:
Type: Surface[]
>An array of tween surfaces if successful, an empty array on error.
Available since:
8.14

/
/
/
CreateTweenSurfacesWithSampling

CreateTweenSurfacesWithSampling method

Class:  Rhino.Geometry.Surface

Nothing found