Description:

Tests a surface to see if it is a portion of a cylinder and return the infinite cylinder.

Syntax:
public bool TryGetCylinder(
out Cylinder cylinder,
double tolerance
)
Parameters:
  • cylinder
  • Type: Cylinder
  • On success, the cylinder parameters are filled in.
  • tolerance
  • Type: double
  • tolerance to use when checking.
Returns:
Type: bool
True if the surface is a portion of a cylinder.
Remarks:
If successful, an infinite cylinder is returned. When a surface has a cylindrical shape, even if its ends are not circles on the cylinder, it returns the axis and radius. You can detect infinite cylinders using Cylinder.IsFinite.
Available since:
5.0

Description:

Tests a surface to see if it is a portion of a cylinder within RhinoMath.ZeroTolerance and return the cylinder.

Syntax:
public bool TryGetCylinder(
out Cylinder cylinder
)
Parameters:
  • cylinder
  • Type: Cylinder
  • On success, the cylinder parameters are filled in.
Returns:
Type: bool
True if the surface is a portion of a cylinder.
Remarks:
If successful, an infinite cylinder is returned. When a surface has a cylindrical shape, even if its ends are not circles on the cylinder, it returns the axis and radius. You can detect infinite cylinders using Cylinder.IsFinite.
Available since:
5.0

/
/
/
TryGetCylinder

TryGetCylinder method

Class:  Rhino.Geometry.Surface

Nothing found