Description:

Splits (divides) the surface into two parts at the specified parameter

Syntax:
public Surface[] Split(
int direction,
double parameter
)
Parameters:
  • direction
  • Type: int
  • 0 = The surface is split vertically. The "west" side is returned as the first surface in the array and the "east" side is returned as the second surface in the array. 1 = The surface is split horizontally. The "south" side is returned as the first surface in the array and the "north" side is returned as the second surface in the array
  • parameter
  • Type: double
  • value of constant parameter in interval returned by Domain(direction)
Returns:
Type: Surface[]
Array of two surfaces on success
Available since:
5.0

Nothing found