Description:

Pulls a 3d curve back to the surface's parameter space.

Syntax:
public Curve Pullback(
Curve curve3d,
double tolerance,
Interval curve3dSubdomain
)
Parameters:
  • curve3d
  • Type: Curve
  • A curve.
  • tolerance
  • Type: double
  • the maximum acceptable 3d distance between from surface(curve_2d(t)) to the locus of points on the surface that are closest to curve_3d.
  • curve3dSubdomain
  • Type: Interval
  • A sub-domain of the curve to sample.
Returns:
Type: Curve
2d curve.
Available since:
5.0

Description:

Pulls a 3d curve back to the surface's parameter space.

Syntax:
public Curve Pullback(
Curve curve3d,
double tolerance
)
Parameters:
  • curve3d
  • Type: Curve
  • The curve to pull.
  • tolerance
  • Type: double
  • the maximum acceptable 3d distance between from surface(curve_2d(t)) to the locus of points on the surface that are closest to curve_3d.
Returns:
Type: Curve
2d curve.
Available since:
5.0

Pullback method

Class:  Rhino.Geometry.Surface

Nothing found