Description:

Constructs a periodic surface from a base surface and a direction.

Syntax:
public static Surface CreatePeriodicSurface(
Surface surface,
int direction,
bool bSmooth
)
Parameters:
  • surface
  • Type: Surface
  • The surface to make periodic.
  • direction
  • Type: int
  • The direction to make periodic, either 0 = U, or 1 = V.
  • bSmooth
  • Type: bool
  • Controls kink removal. If true, smooths any kinks in the surface and moves control points to make a smooth surface. If false, control point locations are not changed or changed minimally (only one point may move) and only the knot vector is altered.
Returns:
Type: Surface
A periodic surface if successful, None on failure.
Available since:
6.0

Description:

Constructs a periodic surface from a base surface and a direction.

Syntax:
public static Surface CreatePeriodicSurface(
Surface surface,
int direction
)
Parameters:
  • surface
  • Type: Surface
  • The surface to make periodic.
  • direction
  • Type: int
  • The direction to make periodic, either 0 = U, or 1 = V.
Returns:
Type: Surface
A Surface on success or None on failure.
Available since:
5.0

/
/
/
CreatePeriodicSurface

CreatePeriodicSurface method

Class:  Rhino.Geometry.Surface

Nothing found