Description:
Constructs a rolling ball fillet between two surfaces.
Parameters:
- surfaceA
- Type: Surface
- A first surface.
- flipA
- Type: bool
- A value that indicates whether A should be used in flipped mode.
- surfaceB
- Type: Surface
- A second surface.
- flipB
- Type: bool
- A value that indicates whether B should be used in flipped mode.
- radius
- Type: double
- A radius value.
- tolerance
- Type: double
- A tolerance value.
Returns:
Type: Surface[]
A new array of rolling ball fillet surfaces; this array can be empty on failure.
Available since:
5.0
Description:
Constructs a rolling ball fillet between two surfaces.
Parameters:
- surfaceA
- Type: Surface
- A first surface.
- uvA
- Type: Point2d
- A point in the parameter space of FaceA near where the fillet is expected to hit the surface.
- surfaceB
- Type: Surface
- A second surface.
- uvB
- Type: Point2d
- A point in the parameter space of FaceB near where the fillet is expected to hit the surface.
- radius
- Type: double
- A radius value.
- tolerance
- Type: double
- A tolerance value used for approximating and intersecting offset surfaces.
Returns:
Type: Surface[]
A new array of rolling ball fillet surfaces; this array can be empty on failure.
Available since:
5.0
Description:
Constructs a rolling ball fillet between two surfaces.