Description:

Constructs closed polysurfaces from surfaces and polysurfaces that bound a region in space.

Syntax:
public static Brep[] CreateSolid(
IEnumerable<Brep> breps,
double tolerance
)
Parameters:
  • breps
  • Type: IEnumerable<Brep>
  • The intersecting surfaces and polysurfaces to automatically trim and join into closed polysurfaces.
  • tolerance
  • Type: double
  • The trim and join tolerance. If set to RhinoMath.UnsetValue, Rhino's global absolute tolerance is used.
Returns:
Type: Brep[]
The resulting polysurfaces on success or None on failure.
Available since:
5.0

CreateSolid method

Class:  Rhino.Geometry.Brep

Nothing found