Description:

Remove all inner loops, or holes, in a Brep.

Syntax:
public Brep RemoveHoles(
double tolerance
)
Parameters:
  • tolerance
  • Type: double
  • The tolerance. When in doubt, use the document's model absolute tolerance.
Returns:
Type: Brep
The Brep without holes if successful, None otherwise.
Available since:
6.0

Description:

Removes inner loops, or holes, in a Brep.

Syntax:
public Brep RemoveHoles(
IEnumerable<ComponentIndex> loops,
double tolerance
)
Parameters:
  • loops
  • Type: IEnumerable<ComponentIndex>
  • A list of BrepLoop component indexes, where BrepLoop.LoopType == Rhino.Geometry.BrepLoopType.Inner.
  • tolerance
  • Type: double
  • The tolerance. When in doubt, use the document's model absolute tolerance.
Returns:
Type: Brep
The Brep without holes if successful, None otherwise.
Available since:
6.8

RemoveHoles method

Class:  Rhino.Geometry.Brep

Nothing found