Description:
Collapses multiple mesh faces, with areas less than LessThanArea and greater than GreaterThanArea, based on the principles found in Stan Melax's mesh reduction PDF, see http://pomax.nihongoresources.com/downloads/PolygonReduction.pdf
Parameters:
- lessThanArea
- Type: double
- Area in which faces are selected if their area is less than or equal to.
- greaterThanArea
- Type: double
- Area in which faces are selected if their area is greater than or equal to.
Returns:
Type: int
Number of faces that were collapsed in the process.
Remarks:
This number may differ from the initial number of faces that meet the input criteria because the areas of some initial faces may be altered as other faces are collapsed. The face area must be both less than LessThanArea AND greater than GreaterThanArea in order to be considered. Use large numbers for lessThanArea or zero for greaterThanArea to simulate an OR.
Available since:
6.0