Description:

Attempts to create a 3d convex hull mesh from input points.

Syntax:
public static Mesh CreateConvexHull3D(
IEnumerable<Point3d> points,
out int[] hullFacets,
double tolerance,
double angleTolerance
)
Parameters:
  • points
  • Type: IEnumerable<Point3d>
  • The 3D input points to be covered with the convex hull. These points must not be coplanar.
  • hullFacets
  • Type: int[]
  • An out parameter of jagged array of indices into the argument point enumerable. Each list item specifies the indices that make up a facet of the convex hull. These indices are not indices into the resulting mesh's indices. Can be the empty jagged array if the resulting mesh is null.
  • tolerance
  • Type: double
  • The tolerance used to decide if points are coplanar or not. Use the document's tolerance if in doubt.
  • angleTolerance
  • Type: double
  • The angle tolerance used for merging coplanar points into facets. Use the document's angle tolerance in radians if in doubt.
Returns:
Type: Mesh
A valid mesh if successful. If there were too few input points, or the input was coplanar up to the specified tolerance, the result can be null.
Available since:
8.5

/
/
/
CreateConvexHull3D

CreateConvexHull3D method

Class:  Rhino.Geometry.Mesh

Nothing found