Description:
Constructs a mesh from an extruded curve. This method is designed for projecting curves onto a mesh. In most cases, a better to use Mesh.CreateExtrusion(Curve, Vector3d) .
Syntax:
public static Mesh CreateFromCurveExtrusion(
Curve curve,
Vector3d direction,
MeshingParameters parameters,
BoundingBox boundingBox
)
Curve curve,
Vector3d direction,
MeshingParameters parameters,
BoundingBox boundingBox
)
Parameters:
- curve
- Type: Curve
- A curve to extrude.
- direction
- Type: Vector3d
- The direction of extrusion.
- parameters
- Type: MeshingParameters
- The parameters of meshing.
- boundingBox
- Type: BoundingBox
- The bounding box controls the length of the extrusion.
Returns:
Type: Mesh
A new mesh, or None on failure.
Available since:
7.0