Description:

Constructs a mesh cylinder.

Syntax:
public static Mesh CreateFromCylinder(
Cylinder cylinder,
int vertical,
int around,
bool capBottom,
bool capTop,
bool circumscribe,
bool quadCaps
)
Parameters:
  • vertical
  • Type: int
  • Number of faces in the top-to-bottom direction.
  • around
  • Type: int
  • Number of faces around the cylinder.
  • capBottom
  • Type: bool
  • If True end at Cylinder.Height1 should be capped.
  • capTop
  • Type: bool
  • If True end at Cylinder.Height2 should be capped.
  • circumscribe
  • Type: bool
  • If True end polygons will circumscribe circle.
  • quadCaps
  • Type: bool
  • If True and it's possible to make quad caps, i.e.. around is even, then caps will have quad faces.
Returns:
Type: Mesh
Returns a mesh cylinder if successful, None otherwise.
Available since:
7.0

Description:

Constructs a mesh cylinder.

Syntax:
public static Mesh CreateFromCylinder(
Cylinder cylinder,
int vertical,
int around,
bool capBottom,
bool capTop,
bool quadCaps
)
Parameters:
  • vertical
  • Type: int
  • Number of faces in the top-to-bottom direction.
  • around
  • Type: int
  • Number of faces around the cylinder.
  • capBottom
  • Type: bool
  • If True end at Cylinder.Height1 should be capped.
  • capTop
  • Type: bool
  • If True end at Cylinder.Height2 should be capped.
  • quadCaps
  • Type: bool
  • If True and it's possible to make quad caps, i.e.. around is even, then caps will have quad faces.
Returns:
Type: Mesh
Returns a mesh cylinder if successful, None otherwise.
Available since:
7.0

Description:

Constructs a mesh cylinder.

Syntax:
public static Mesh CreateFromCylinder(
Cylinder cylinder,
int vertical,
int around,
bool capBottom,
bool capTop
)
Parameters:
  • vertical
  • Type: int
  • Number of faces in the top-to-bottom direction.
  • around
  • Type: int
  • Number of faces around the cylinder.
  • capBottom
  • Type: bool
  • If True end at Cylinder.Height1 should be capped.
  • capTop
  • Type: bool
  • If True end at Cylinder.Height2 should be capped.
Returns:
Type: Mesh
Returns a mesh cylinder if successful, None otherwise.
Available since:
7.0

Description:

Constructs a capped mesh cylinder.

Syntax:
public static Mesh CreateFromCylinder(
Cylinder cylinder,
int vertical,
int around
)
Parameters:
  • vertical
  • Type: int
  • Number of faces in the top-to-bottom direction.
  • around
  • Type: int
  • Number of faces around the cylinder.
Returns:
Type: Mesh
Returns a mesh cylinder if successful, None otherwise.
Available since:
5.0

/
/
/
CreateFromCylinder

CreateFromCylinder method

Class:  Rhino.Geometry.Mesh

Nothing found