Description:

Constructs a mesh cone.

Syntax:
public static Mesh CreateFromCone(
Cone cone,
int vertical,
int around,
bool solid,
bool quadCaps
)
Parameters:
  • vertical
  • Type: int
  • Number of faces in the top-to-bottom direction.
  • around
  • Type: int
  • Number of faces around the cone.
  • solid
  • Type: bool
  • If False the mesh will be open with no faces on the circular planar portion.
  • quadCaps
  • Type: bool
  • If True and it's possible to make quad caps, i.e.. around is even, then caps will have quad faces.
Returns:
Type: Mesh
A valid mesh if successful.
Available since:
7.0

Description:

Constructs a mesh cone.

Syntax:
public static Mesh CreateFromCone(
Cone cone,
int vertical,
int around,
bool solid
)
Parameters:
  • vertical
  • Type: int
  • Number of faces in the top-to-bottom direction.
  • around
  • Type: int
  • Number of faces around the cone.
  • solid
  • Type: bool
  • If False the mesh will be open with no faces on the circular planar portion.
Returns:
Type: Mesh
A valid mesh if successful.
Available since:
6.8

Description:

Constructs a solid mesh cone.

Syntax:
public static Mesh CreateFromCone(
Cone cone,
int vertical,
int around
)
Parameters:
  • vertical
  • Type: int
  • Number of faces in the top-to-bottom direction.
  • around
  • Type: int
  • Number of faces around the cone.
Returns:
Type: Mesh
A valid mesh if successful.
Available since:
5.0

/
/
/
CreateFromCone

CreateFromCone method

Class:  Rhino.Geometry.Mesh

Nothing found