Description:
Splits a mesh by adding edges in correspondence with input polylines, and divides the mesh at partitioned areas. Polyline segments that are measured not to be on the mesh will be ignored.
Parameters:
- curves
- Type: IEnumerable<PolylineCurve>
- An array, a list or any enumerable of polyline curves.
- tolerance
- Type: double
- A tolerance value.
- textLog
- Type: TextLog
- A text log, or null.
- cancel
- Type: System.Threading.CancellationToken
- A cancellation token to stop the computation at a given point.
- progress
- Type: IProgress<double>
- A progress reporter to inform the user about progress. The reported value is indicative.
Returns:
Type: Mesh[]
An array of meshes, or None if no change would happen.
Available since:
7.0
Description:
Splits a mesh by adding edges in correspondence with input polylines, and divides the mesh at partitioned areas. Polyline segments that are measured not to be on the mesh will be ignored.