Description:

Attempts to fix inconsistencies in the directions of mesh faces in a mesh. This function does not modify mesh vertex normals, it rearranges the mesh face winding and face normals to make them all consistent. Note, you may want to call Mesh.Normals.ComputeNormals() to recompute vertex normals after calling this functions.

Syntax:
public int UnifyNormals()
Returns:
Type: int
number of faces that were modified.
Available since:
5.0

Description:

Attempts to fix inconsistencies in the directions of mesh faces in a mesh. This function does not modify mesh vertex normals, it rearranges the mesh face winding and face normals to make them all consistent. Note, you may want to call Mesh.Normals.ComputeNormals() to recompute vertex normals after calling this functions.

Syntax:
public int UnifyNormals(
bool countOnly
)
Parameters:
  • countOnly
  • Type: bool
  • If true, then only the number of faces that would be modified is determined.
Returns:
Type: int
If countOnly=false, the number of faces that were modified. If countOnly=true, the number of faces that would be modified.
Available since:
6.0

/
/
/
UnifyNormals

UnifyNormals method

Class:  Rhino.Geometry.Mesh

Nothing found