Description:

Evaluate a mesh normal at a set of barycentric coordinates. Barycentric coordinates must be assigned in accordance with the rules as defined by MeshPoint.T .

Syntax:
public Color ColorAt(
int faceIndex,
double t0,
double t1,
double t2,
double t3
)
Parameters:
  • faceIndex
  • Type: int
  • Index of triangle or quad to evaluate.
  • t0
  • Type: double
  • First barycentric coordinate.
  • t1
  • Type: double
  • Second barycentric coordinate.
  • t2
  • Type: double
  • Third barycentric coordinate.
  • t3
  • Type: double
  • Fourth barycentric coordinate. If the face is a triangle, this coordinate will be ignored.
Returns:
Type: Color
The interpolated vertex color on the mesh or Color.Transparent if the faceIndex is not valid, if the barycentric coordinates could not be evaluated, or if there are no colors defined on the mesh.
Remarks:
Coordinate 0,0,0,0 is not a valid set of barycentric coordinates. The sum of t0 to t3 should be 1.
Available since:
5.0

Description:

Evaluate a mesh color at a set of barycentric coordinates.

Syntax:
public Color ColorAt(
MeshPoint meshPoint
)
Parameters:
  • meshPoint
  • Type: MeshPoint
  • MeshPoint instance containing a valid Face Index and Barycentric coordinates.
Returns:
Type: Color
The interpolated vertex color on the mesh or Color.Transparent if the faceIndex is not valid, if the barycentric coordinates could not be evaluated, or if there are no colors defined on the mesh.
Available since:
5.0

ColorAt method

Class:  Rhino.Geometry.Mesh

Nothing found