Description:

Makes a new mesh with vertices offset a distance along the direction parameter. Optionally, based on the value of solidify, adds the input mesh and a ribbon of faces along any naked edges. If solidify is False it acts exactly as the Offset(distance) function. Returns list of wall faces, i.e. the faces that connect original and offset mesh when solidified.

Syntax:
public Mesh Offset(
double distance,
bool solidify,
Vector3d direction,
out List<int> wallFacesOut
)
Parameters:
  • distance
  • Type: double
  • A distance value.
  • solidify
  • Type: bool
  • True if the mesh should be solidified.
  • direction
  • Type: Vector3d
  • Direction of offset for all vertices.
  • wallFacesOut
  • Type: List<int>
  • Returns list of wall faces.
Returns:
Type: Mesh
A new mesh on success, or None on failure.

Description:

Makes a new mesh with vertices offset a distance along the direction parameter. Optionally, based on the value of solidify, adds the input mesh and a ribbon of faces along any naked edges. If solidify is False it acts exactly as the Offset(distance) function.

Syntax:
public Mesh Offset(
double distance,
bool solidify,
Vector3d direction
)
Parameters:
  • distance
  • Type: double
  • A distance value.
  • solidify
  • Type: bool
  • True if the mesh should be solidified.
  • direction
  • Type: Vector3d
  • Direction of offset for all vertices.
Returns:
Type: Mesh
A new mesh on success, or None on failure.
Available since:
6.2

Description:

Makes a new mesh with vertices offset a distance in the opposite direction of the existing vertex normals. Optionally, based on the value of solidify, adds the input mesh and a ribbon of faces along any naked edges. If solidify is False it acts exactly as the Offset(distance) function.

Syntax:
public Mesh Offset(
double distance,
bool solidify
)
Parameters:
  • distance
  • Type: double
  • A distance value.
  • solidify
  • Type: bool
  • True if the mesh should be solidified.
Returns:
Type: Mesh
A new mesh on success, or None on failure.
Available since:
5.0

Description:

Makes a new mesh with vertices offset a distance in the opposite direction of the existing vertex normals. Same as Mesh.Offset(distance, false)

Syntax:
public Mesh Offset(
double distance
)
Parameters:
  • distance
  • Type: double
  • A distance value to use for offsetting.
Returns:
Type: Mesh
A new mesh on success, or None on failure.
Available since:
5.0

Offset method

Class:  Rhino.Geometry.Mesh

Nothing found