Description:

Constructs a sub-mesh, that contains a filtered list of faces.

Syntax:
public static Mesh CreateFromFilteredFaceList(
Mesh original,
IEnumerable<bool> inclusion
)
Parameters:
  • original
  • Type: Mesh
  • The mesh to copy. If null, None is returned.
  • inclusion
  • Type: IEnumerable<bool>
  • A series of True and False values, that determine if each face is used in the new mesh. If None or empty, a non-filtered copy of the original mesh is returned. If the amount does not match the length of the face list, the pattern is repeated. If it exceeds the amount of faces in the mesh face list, the pattern is truncated.
Returns:
Type: Mesh
A copy of the original mesh with its faces filtered, or None on failure.
Available since:
7.0

/
/
/
CreateFromFilteredFaceList

CreateFromFilteredFaceList method

Class:  Rhino.Geometry.Mesh

Nothing found