Description:

Computes the solid union of a set of meshes.

Syntax:
public static Mesh[] CreateBooleanUnion(
IEnumerable<Mesh> meshes,
double tolerance
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • Meshes to union.
  • tolerance
  • Type: double
  • A valid tolerance value. See Intersect.Intersection.MeshIntersectionsTolerancesCoefficient
Returns:
Type: Mesh[]
An array of Mesh results or None on failure.
Available since:
8.0

Description:

Computes the solid union of a set of meshes.

Syntax:
public static Mesh[] CreateBooleanUnion(
IEnumerable<Mesh> meshes,
MeshBooleanOptions options,
out Result commandResult
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • Meshes to union.
  • options
  • Type: MeshBooleanOptions
  • An option instance. Can be null, but generally it should be instantiated and have a tolerance set.
  • commandResult
  • Type: Commands.Result
  • A value indicating if the function was successful, or if it was cancelled, or if it did nothing, or failed.
Returns:
Type: Mesh[]
Available since:
8.0

Description:

Computes the solid union of a set of meshes. WARNING: Use the overload that takes a tolerance or options.

Syntax:
public static Mesh[] CreateBooleanUnion(
IEnumerable<Mesh> meshes
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • Meshes to union.
Returns:
Type: Mesh[]
An array of Mesh results or None on failure.
Available since:
5.0

/
/
/
CreateBooleanUnion

CreateBooleanUnion method

Class:  Rhino.Geometry.Mesh

Nothing found