Description:

Merges adjacent coplanar faces into single faces.

Syntax:
public bool MergeAllCoplanarFaces(
double tolerance,
double angleTolerance
)
Parameters:
  • tolerance
  • Type: double
  • Tolerance for determining when edges are adjacent. When in doubt, use the document's ModelAbsoluteTolerance property.
  • angleTolerance
  • Type: double
  • Angle tolerance, in radians, for determining when faces are parallel. When in doubt, use the document's ModelAngleToleranceRadians property.
Returns:
Type: bool
True if faces were merged, False if no faces were merged.
Available since:
7.9

Description:

Merges adjacent coplanar faces into single faces.

Syntax:
public bool MergeAllCoplanarFaces(
double tolerance
)
Parameters:
  • tolerance
  • Type: double
  • Tolerance for determining when edges are adjacent. When in doubt, use the document's ModelAbsoluteTolerance property.
Returns:
Type: bool
True if faces were merged, False if no faces were merged.
Available since:
7.9

/
/
/
MergeAllCoplanarFaces

MergeAllCoplanarFaces method

Class:  Rhino.Geometry.Mesh

Nothing found