Description:

Evaluate a mesh normal at a set of barycentric coordinates. Barycentric coordinates must be assigned in accordance with the rules as defined by MeshPoint.T.

Syntax:
public Vector3d NormalAt(
int faceIndex,
double t0,
double t1,
double t2,
double t3
)
Parameters:
  • faceIndex
  • Type: int
  • Index of triangle or quad to evaluate.
  • t0
  • Type: double
  • First barycentric coordinate.
  • t1
  • Type: double
  • Second barycentric coordinate.
  • t2
  • Type: double
  • Third barycentric coordinate.
  • t3
  • Type: double
  • Fourth barycentric coordinate. If the face is a triangle, this coordinate will be ignored.
Returns:
Type: Vector3d
A Normal vector to the mesh or Vector3d.Unset if the faceIndex is not valid or if the barycentric coordinates could not be evaluated.
Available since:
5.0

Description:

Evaluate a mesh normal at a set of barycentric coordinates.

Syntax:
public Vector3d NormalAt(
MeshPoint meshPoint
)
Parameters:
  • meshPoint
  • Type: MeshPoint
  • MeshPoint instance containing a valid Face Index and Barycentric coordinates.
Returns:
Type: Vector3d
A Normal vector to the mesh or Vector3d.Unset if the faceIndex is not valid or if the barycentric coordinates could not be evaluated.
Available since:
5.0

NormalAt method

Class:  Rhino.Geometry.Mesh

Nothing found