Description:

Gets the intersections of this mesh with itself.

Syntax:
public bool GetSelfIntersections(
double tolerance,
out Polyline[] perforations,
bool overlapsPolylines,
out Polyline[] overlapsPolylinesResult,
bool overlapsMesh,
out Mesh overlapsMeshResult,
TextLog textLog,
CancellationToken cancel,
IProgress<double> progress
)
Parameters:
  • tolerance
  • Type: double
  • A tolerance value. If negative, the positive value will be used. WARNING! Good tolerance values are in the magnitude of 10^-7, or RhinoMath.SqrtEpsilon*10.
  • perforations
  • Type: Polyline[]
  • The array of perforations.
  • overlapsPolylines
  • Type: bool
  • If true, the next argument is computed.
  • overlapsPolylinesResult
  • Type: Polyline[]
  • The array of overlaps, in terms of polylines.
  • overlapsMesh
  • Type: bool
  • If true, the next argument is computed.
  • overlapsMeshResult
  • Type: Mesh
  • A mesh that represents the overlaps in terms of surfaces.
  • cancel
  • Type: System.Threading.CancellationToken
  • A cancellation token.
  • progress
  • Type: IProgress<double>
  • A progress reporter.
Returns:
Type: bool
An array of intersection and overlaps polylines.
Available since:
7.0

/
/
/
GetSelfIntersections

GetSelfIntersections method

Class:  Rhino.Geometry.Mesh

Nothing found