Description:

Returns cached texture coordinate set based on the texture. Make sure to set up cached texture coordinates for all textures in the material first by calling SetCachedTextureCoordinatesFromMaterial(RhinoObject rhinoObject, Rhino.DocObjects.Material material) If this function returns None then there are no texture coordinates available.

Syntax:
public CachedTextureCoordinates GetCachedTextureCoordinates(
RhinoObject rhinoObject,
Texture texture
)
Parameters:
  • rhinoObject
  • Type: RhinoObject
  • RhinoObject that defines texture mappings
Returns:
Cached texture coordinates if available and otherwise null
Available since:
8.7

Description:

Call this method to get cached texture coordinates for a texture mapping with the specified Id.

Syntax:
public CachedTextureCoordinates GetCachedTextureCoordinates(
Guid textureMappingId
)
Parameters:
  • textureMappingId
  • Type: System.Guid
  • Texture mapping Id
Returns:
Object which allows access to coordinates and other props.
Available since:
5.10

/
/
/
GetCachedTextureCoordinates

GetCachedTextureCoordinates method

Class:  Rhino.Geometry.Mesh

Nothing found