Description:

Creates a unified ShrinkWrap mesh from a collection of GeometryBase objects. returns None or error on failure

Syntax:
public static Mesh ShrinkWrap(
IEnumerable<GeometryBase> geometryBases,
ShrinkWrapParameters parameters,
MeshingParameters meshingParameters
)
Parameters:
  • geometryBases
  • Type: IEnumerable<GeometryBase>
  • parameters
  • Type: ShrinkWrapParameters
  • A ShrinkWrapParameters object that specifies the configuration settings for the ShrinkWrap process.
  • meshingParameters
  • Type: MeshingParameters
  • GeometryBase objects are converted to meshes first using the MeshingParameters provided. Those meshes are then used in the ShrinkWrap process.
Returns:
Type: Mesh
Available since:
8.3

Description:

Creates a unified ShrinkWrap mesh from a collection of input meshes. Returns None on error or failure.

Syntax:
public static Mesh ShrinkWrap(
IEnumerable<Mesh> meshes,
ShrinkWrapParameters parameters
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • parameters
  • Type: ShrinkWrapParameters
  • A ShrinkWrapParameters object that specifies the configuration settings for the ShrinkWrap process.
Returns:
Type: Mesh
Available since:
8.0

Description:

Creates a unified ShrinkWrap mesh from a point cloud returns None on error or failure

Syntax:
public static Mesh ShrinkWrap(
PointCloud pointCloud,
ShrinkWrapParameters parameters
)
Returns:
Type: Mesh
Available since:
8.0

Description:

Returns a ShrinkWrapped mesh or None when a mesh was not created or error.

Syntax:
public Mesh ShrinkWrap(
ShrinkWrapParameters parameters,
CancellationToken token
)
Parameters:
  • parameters
  • Type: ShrinkWrapParameters
  • A ShrinkWrapParameters object that specifies the configuration settings for the ShrinkWrap process.
  • token
  • Type: System.Threading.CancellationToken
  • A cancellation token
Returns:
Type: Mesh
Available since:
8.0

Description:

Returns a ShrinkWrapped mesh or None when a mesh was not created or error.

Syntax:
public Mesh ShrinkWrap(
ShrinkWrapParameters parameters
)
Parameters:
  • parameters
  • Type: ShrinkWrapParameters
  • A ShrinkWrapParameters object that specifies the configuration settings for the ShrinkWrap process.
Returns:
Type: Mesh
Available since:
8.0

ShrinkWrap method

Class:  Rhino.Geometry.Mesh

Nothing found