Description:

Constructs a new mesh pipe from a curve.

Syntax:
public static Mesh CreateFromCurvePipe(
Curve curve,
double radius,
int segments,
int accuracy,
MeshPipeCapStyle capType,
bool faceted,
IEnumerable<Interval> intervals
)
Parameters:
  • curve
  • Type: Curve
  • A curve to pipe.
  • radius
  • Type: double
  • The radius of the pipe.
  • segments
  • Type: int
  • The number of segments in the pipe.
  • accuracy
  • Type: int
  • The accuracy of the pipe.
  • capType
  • Type: MeshPipeCapStyle
  • The type of cap to be created at the end of the pipe.
  • faceted
  • Type: bool
  • Specifies whether the pipe is faceted, or not.
  • intervals
  • Type: IEnumerable<Interval>
  • A series of intervals to pipe. This value can be null.
Returns:
Type: Mesh
A new mesh, or None on failure.
Available since:
6.0

/
/
/
CreateFromCurvePipe

CreateFromCurvePipe method

Class:  Rhino.Geometry.Mesh

Nothing found