Description:

Constructs a quad mesh sphere. A quad mesh sphere differs from a standard UV mesh sphere in that it's vertices are evenly distributed. A quad mesh sphere starts from a cube (a regular polyhedron with 6 square sides). It is then refined by splitting each quad into 4 smaller quads. This splitting can be done several times.

Syntax:
public static Mesh CreateQuadSphere(
Sphere sphere,
int subdivisions
)
Parameters:
  • sphere
  • Type: Sphere
  • The input sphere provides the orienting plane and radius.
  • subdivisions
  • Type: int
  • The number of times you want the faces split, where 0 <= subdivisions <= 8. Note, the total number of mesh faces produces is: 6 * (4 ^ subdivisions)
Returns:
Type: Mesh
A welded quad mesh sphere if successful, or None on failure.
Available since:
6.0

/
/
/
CreateQuadSphere

CreateQuadSphere method

Class:  Rhino.Geometry.Mesh

Nothing found