Description:

Gets a polyline approximation of the input curve and then moves its control points to the closest point on the mesh. Then it "connects the points" over edges so that a polyline on the mesh is formed.

Syntax:
public PolylineCurve PullCurve(
Curve curve,
double tolerance
)
Parameters:
  • curve
  • Type: Curve
  • A curve to pull.
  • tolerance
  • Type: double
  • A tolerance value.
Returns:
A polyline curve, or None if none could be constructed.
Available since:
7.0

PullCurve method

Class:  Rhino.Geometry.Mesh

Nothing found