Description:

Determines if a point is inside a solid mesh.

Syntax:
public bool IsPointInside(
Point3d point,
double tolerance,
bool strictlyIn
)
Parameters:
  • point
  • Type: Point3d
  • 3d point to test.
  • tolerance
  • Type: double
  • (>=0) 3d distance tolerance used for ray-mesh intersection and determining strict inclusion. This is expected to be a tiny value.
  • strictlyIn
  • Type: bool
  • If strictlyIn is true, then point must be inside mesh by at least tolerance in order for this function to return true. If strictlyIn is false, then this function will return True if point is inside or the distance from point to a mesh face is <= tolerance.
Returns:
Type: bool
True if point is inside the solid mesh, False if not.
Remarks:
The caller is responsible for making certain the mesh is valid, closed, and 2-manifold before calling this function. If the mesh is not, the behavior is undetermined.
Available since:
5.0

/
/
/
IsPointInside

IsPointInside method

Class:  Rhino.Geometry.Mesh

Nothing found