Description:

Makes sure that faces sharing an edge and having a difference of normal greater than or equal to angleToleranceRadians have unique vertices along that edge, adding vertices if necessary.

Syntax:
public void Unweld(
double angleToleranceRadians,
bool modifyNormals
)
Parameters:
  • angleToleranceRadians
  • Type: double
  • Angle at which to make unique vertices.
  • modifyNormals
  • Type: bool
  • Determines whether new vertex normals will have the same vertex normal as the original (false) or vertex normals made from the corresponding face normals (true)
Returns:
Type: void
Available since:
5.0

Unweld method

Class:  Rhino.Geometry.Mesh

Nothing found