Description:

Reduce polygon count

Syntax:
public bool Reduce(
int desiredPolygonCount,
bool allowDistortion,
int accuracy,
bool normalizeSize,
bool threaded
)
Parameters:
  • desiredPolygonCount
  • Type: int
  • desired or target number of faces
  • allowDistortion
  • Type: bool
  • If True mesh appearance is not changed even if the target polygon count is not reached
  • accuracy
  • Type: int
  • Integer from 1 to 10 telling how accurate reduction algorithm to use. Greater number gives more accurate results
  • normalizeSize
  • Type: bool
  • If True mesh is fitted to an axis aligned unit cube until reduction is complete
  • threaded
  • Type: bool
  • If True then will run computation inside a worker thread and ignore any provided CancellationTokens and ProgressReporters. If False then will run on main thread.
Returns:
Type: bool
True if mesh is successfully reduced and False if mesh could not be reduced for some reason.
Available since:
6.15

Description:

Reduce polygon count

Syntax:
public bool Reduce(
int desiredPolygonCount,
bool allowDistortion,
int accuracy,
bool normalizeSize,
CancellationToken cancelToken,
IProgress<double> progress,
out string problemDescription,
bool threaded
)
Parameters:
  • desiredPolygonCount
  • Type: int
  • desired or target number of faces
  • allowDistortion
  • Type: bool
  • If True mesh appearance is not changed even if the target polygon count is not reached
  • accuracy
  • Type: int
  • Integer from 1 to 10 telling how accurate reduction algorithm to use. Greater number gives more accurate results
  • normalizeSize
  • Type: bool
  • If True mesh is fitted to an axis aligned unit cube until reduction is complete
  • cancelToken
  • Type: System.Threading.CancellationToken
  • progress
  • Type: IProgress<double>
  • problemDescription
  • Type: string
  • threaded
  • Type: bool
  • If True then will run computation inside a worker thread and ignore any provided CancellationTokens and ProgressReporters. If False then will run on main thread.
Returns:
Type: bool
True if mesh is successfully reduced and False if mesh could not be reduced for some reason.
Available since:
6.15

Description:

Reduce polygon count

Syntax:
public bool Reduce(
int desiredPolygonCount,
bool allowDistortion,
int accuracy,
bool normalizeSize,
CancellationToken cancelToken,
IProgress<double> progress,
out string problemDescription
)
Parameters:
  • desiredPolygonCount
  • Type: int
  • desired or target number of faces
  • allowDistortion
  • Type: bool
  • If True mesh appearance is not changed even if the target polygon count is not reached
  • accuracy
  • Type: int
  • Integer from 1 to 10 telling how accurate reduction algorithm to use. Greater number gives more accurate results
  • normalizeSize
  • Type: bool
  • If True mesh is fitted to an axis aligned unit cube until reduction is complete
  • cancelToken
  • Type: System.Threading.CancellationToken
  • progress
  • Type: IProgress<double>
  • problemDescription
  • Type: string
Returns:
Type: bool
True if mesh is successfully reduced and False if mesh could not be reduced for some reason.
Available since:
6.0

Description:

Reduce polygon count

Syntax:
public bool Reduce(
int desiredPolygonCount,
bool allowDistortion,
int accuracy,
bool normalizeSize
)
Parameters:
  • desiredPolygonCount
  • Type: int
  • desired or target number of faces
  • allowDistortion
  • Type: bool
  • If True mesh appearance is not changed even if the target polygon count is not reached
  • accuracy
  • Type: int
  • Integer from 1 to 10 telling how accurate reduction algorithm to use. Greater number gives more accurate results
  • normalizeSize
  • Type: bool
  • If True mesh is fitted to an axis aligned unit cube until reduction is complete
Returns:
Type: bool
True if mesh is successfully reduced and False if mesh could not be reduced for some reason.
Available since:
5.10

Description:

Reduce polygon count

Syntax:
public bool Reduce(
ReduceMeshParameters parameters,
bool threaded
)
Parameters:
  • threaded
  • Type: bool
  • If True then will run computation inside a worker thread and ignore any provided CancellationTokens and ProgressReporters. If False then will run on main thread.
Returns:
Type: bool
True if mesh is successfully reduced and False if mesh could not be reduced for some reason.
Available since:
6.15

Description:

Reduce polygon count

Syntax:
public bool Reduce(
ReduceMeshParameters parameters
)
Parameters:
Returns:
Type: bool
True if mesh is successfully reduced and False if mesh could not be reduced for some reason.
Available since:
6.0

Reduce method

Class:  Rhino.Geometry.Mesh

Nothing found