Description:

Analyzes some meshes, and determines if a pass of CreateFromIterativeCleanup would change the array. All available cleanup steps are used. Currently available cleanup steps are: - mending of single precision coincidence even though double precision vertices differ. - union of nearly identical vertices, irrespectively of their origin. - removal of t-joints along edges.

Syntax:
public static bool RequireIterativeCleanup(
IEnumerable<Mesh> meshes,
double tolerance
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • A list, and array or any enumerable of meshes.
  • tolerance
  • Type: double
  • A 3d distance. This is usually a value of about 10e-7 magnitude.
Returns:
Type: bool
True if meshes would be changed, otherwise false.
Remarks:
Rhino.Geometry.Mesh.CreateFromIterativeCleanup
Available since:
7.0

/
/
/
RequireIterativeCleanup

RequireIterativeCleanup method

Class:  Rhino.Geometry.Mesh

Nothing found