Description:

Constructs contour curves for a mesh, sectioned at a plane.

Syntax:
public static Curve[] CreateContourCurves(
Mesh meshToContour,
Plane sectionPlane,
double tolerance
)
Parameters:
  • meshToContour
  • Type: Mesh
  • A mesh to contour.
  • sectionPlane
  • Type: Plane
  • A cutting plane.
  • tolerance
  • Type: double
  • A tolerance value. If negative, the positive value will be used. WARNING! Good tolerance values are in the magnitude of 10^-7, or RhinoMath.SqrtEpsilon*10. See comments at Intersect.Intersection.MeshIntersectionsTolerancesCoefficient
Returns:
Type: Curve[]
An array of curves. This array can be empty.
Available since:
7.13

Description:

(Old call maintained for compatibility.)

Syntax:
public static Curve[] CreateContourCurves(
Mesh meshToContour,
Plane sectionPlane
)
deprecated in 7.13
obsolete: Prefer the option that takes a tolerance value.
Parameters:
  • meshToContour
  • Type: Mesh
  • Avoid.
  • sectionPlane
  • Type: Plane
  • Avoid.
Returns:
Type: Curve[]
Avoid.
Available since:
5.0

Description:

Constructs contour curves for a mesh, sectioned along a linear axis.

Syntax:
public static Curve[] CreateContourCurves(
Mesh meshToContour,
Point3d contourStart,
Point3d contourEnd,
double interval,
double tolerance
)
Parameters:
  • meshToContour
  • Type: Mesh
  • A mesh to contour.
  • contourStart
  • Type: Point3d
  • A start point of the contouring axis.
  • contourEnd
  • Type: Point3d
  • An end point of the contouring axis.
  • interval
  • Type: double
  • An interval distance.
  • tolerance
  • Type: double
  • A tolerance value. If negative, the positive value will be used. WARNING! Good tolerance values are in the magnitude of 10^-7, or RhinoMath.SqrtEpsilon*10. See comments at Intersect.Intersection.MeshIntersectionsTolerancesCoefficient
Returns:
Type: Curve[]
An array of curves. This array can be empty.
Available since:
7.13

Description:

(Old call maintained for compatibility.)

Syntax:
public static Curve[] CreateContourCurves(
Mesh meshToContour,
Point3d contourStart,
Point3d contourEnd,
double interval
)
deprecated in 7.13
obsolete: Prefer the overload that takes a tolerance value.
Parameters:
  • meshToContour
  • Type: Mesh
  • Avoid.
Returns:
Type: Curve[]
Avoid.
Available since:
5.0

/
/
/
CreateContourCurves

CreateContourCurves method

Class:  Rhino.Geometry.Mesh

Nothing found