Description:

Constructs a icospherical mesh. A mesh icosphere differs from a standard UV mesh sphere in that it's vertices are evenly distributed. A mesh icosphere starts from an icosahedron (a regular polyhedron with 20 equilateral triangles). It is then refined by splitting each triangle into 4 smaller triangles. This splitting can be done several times.

Syntax:
public static Mesh CreateIcoSphere(
Sphere sphere,
int subdivisions
)
Parameters:
  • sphere
  • Type: Sphere
  • The input sphere provides the orienting plane and radius.
  • subdivisions
  • Type: int
  • The number of times you want the faces split, where 0 <= subdivisions <= 7. Note, the total number of mesh faces produces is: 20 * (4 ^ subdivisions)
Returns:
Type: Mesh
A welded mesh icosphere if successful, or None on failure.
Available since:
6.0

/
/
/
CreateIcoSphere

CreateIcoSphere method

Class:  Rhino.Geometry.Mesh

Nothing found