Description:

Compute thickness metrics for this mesh.

Syntax:
public static MeshThicknessMeasurement[] ComputeThickness(
IEnumerable<Mesh> meshes,
double maximumThickness,
double sharpAngle,
CancellationToken cancelToken
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • Meshes to include in thickness analysis.
  • maximumThickness
  • Type: double
  • Maximum thickness to consider. Use as small a thickness as possible to speed up the solver.
  • sharpAngle
  • Type: double
  • Sharpness angle in radians.
  • cancelToken
  • Type: System.Threading.CancellationToken
  • Computation cancellation token.
Returns:
Array of thickness measurements.
Available since:
6.0

Description:

Compute thickness metrics for this mesh.

Syntax:
public static MeshThicknessMeasurement[] ComputeThickness(
IEnumerable<Mesh> meshes,
double maximumThickness,
CancellationToken cancelToken
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • Meshes to include in thickness analysis.
  • maximumThickness
  • Type: double
  • Maximum thickness to consider. Use as small a thickness as possible to speed up the solver.
  • cancelToken
  • Type: System.Threading.CancellationToken
  • Computation cancellation token.
Returns:
Array of thickness measurements.
Available since:
6.0

Description:

Compute thickness metrics for this mesh.

Syntax:
public static MeshThicknessMeasurement[] ComputeThickness(
IEnumerable<Mesh> meshes,
double maximumThickness
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • Meshes to include in thickness analysis.
  • maximumThickness
  • Type: double
  • Maximum thickness to consider. Use as small a thickness as possible to speed up the solver.
Returns:
Array of thickness measurements.
Available since:
6.0

/
/
/
ComputeThickness

ComputeThickness method

Class:  Rhino.Geometry.Mesh

Nothing found