Description:
Splits a set of meshes with another set.
Syntax:
public static Mesh[] CreateBooleanSplit(
IEnumerable<Mesh> meshesToSplit,
IEnumerable<Mesh> meshSplitters,
MeshBooleanOptions options,
out Result result
)
IEnumerable<Mesh> meshesToSplit,
IEnumerable<Mesh> meshSplitters,
MeshBooleanOptions options,
out Result result
)
Parameters:
- meshesToSplit
- Type: IEnumerable<Mesh>
- A list, an array, or any enumerable set of meshes to be split. If this is null, None will be returned.
- meshSplitters
- Type: IEnumerable<Mesh>
- A list, an array, or any enumerable set of meshes that cut. If this is null, None will be returned.
- options
- Type: MeshBooleanOptions
- The boolean option instance, or null.
- result
- Type: Result
- A value indicating success, or cancel, or failure, or nothing.
Returns:
Type: Mesh[]
A new mesh array, or None on error.
Available since:
5.0
Description:
Splits a set of meshes with another set.
Syntax:
public static Mesh[] CreateBooleanSplit(
IEnumerable<Mesh> meshesToSplit,
IEnumerable<Mesh> meshSplitters
)
IEnumerable<Mesh> meshesToSplit,
IEnumerable<Mesh> meshSplitters
)
Parameters:
- meshesToSplit
- Type: IEnumerable<Mesh>
- A list, an array, or any enumerable set of meshes to be split. If this is null, None will be returned.
- meshSplitters
- Type: IEnumerable<Mesh>
- A list, an array, or any enumerable set of meshes that cut. If this is null, None will be returned.
Returns:
Type: Mesh[]
A new mesh array, or None on error.
Available since:
5.0