Description:
Constructs new mesh from the current one, with edge softening applied to it.
Parameters:
- softeningRadius
- Type: double
- The softening radius.
- chamfer
- Type: bool
- Specifies whether to chamfer the edges.
- faceted
- Type: bool
- Specifies whether the edges are faceted.
- force
- Type: bool
- Specifies whether to soften edges despite too large a radius.
- angleThreshold
- Type: double
- Threshold angle (in degrees) which controls whether an edge is softened or not. The angle refers to the angles between the adjacent faces of an edge.
Returns:
Type: Mesh
A new mesh with soft edges.
Available since:
6.0