Description:

Given a starting "naked" edge index, this function attempts to determine a "hole" by chaining additional naked edges together until if returns to the start index. Then it triangulates the closed polygon and either adds the faces to the mesh.

Syntax:
public bool FileHole(
int topologyEdgeIndex
)
Parameters:
  • topologyEdgeIndex
  • Type: int
  • Starting naked edge index.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
6.0

FileHole method

Class:  Rhino.Geometry.Mesh

Nothing found