Description:

Split a mesh with a collection of meshes.

Syntax:
public Mesh[] Split(
IEnumerable<Mesh> meshes,
double tolerance,
bool splitAtCoplanar,
bool createNgons,
TextLog textLog,
CancellationToken cancel,
IProgress<double> progress
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • Meshes to split with.
  • tolerance
  • Type: double
  • A value for intersection tolerance. WARNING! Correct values are typically in the (10e-8 - 10e-4) range. An option is to use the document tolerance diminished by a few orders or magnitude.
  • splitAtCoplanar
  • Type: bool
  • If false, coplanar areas will not be separated.
  • createNgons
  • Type: bool
  • If true, creates ngons along the split ridge.
  • textLog
  • Type: TextLog
  • A text log to write onto.
  • cancel
  • Type: System.Threading.CancellationToken
  • A cancellation token.
  • progress
  • Type: IProgress<double>
  • A progress reporter item. This can be null.
Returns:
Type: Mesh[]
An array of mesh parts representing the split result, or null: when no mesh intersected, or if a cancel stopped the computation.
Available since:
7.0

Description:

Split a mesh with a collection of meshes.

Syntax:
public Mesh[] Split(
IEnumerable<Mesh> meshes,
double tolerance,
bool splitAtCoplanar,
TextLog textLog,
CancellationToken cancel,
IProgress<double> progress
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • Meshes to split with.
  • tolerance
  • Type: double
  • A value for intersection tolerance. WARNING! Correct values are typically in the (10e-8 - 10e-4) range. An option is to use the document tolerance diminished by a few orders or magnitude.
  • splitAtCoplanar
  • Type: bool
  • If false, coplanar areas will not be separated.
  • textLog
  • Type: TextLog
  • A text log to write onto.
  • cancel
  • Type: System.Threading.CancellationToken
  • A cancellation token.
  • progress
  • Type: IProgress<double>
  • A progress reporter item. This can be null.
Returns:
Type: Mesh[]
An array of mesh parts representing the split result, or null: when no mesh intersected, or if a cancel stopped the computation.
Available since:
7.0

Description:

Split a mesh with a collection of meshes. Suggestion: upgrade to overload with tolerance. Does not split at coplanar intersections.

Syntax:
public Mesh[] Split(
IEnumerable<Mesh> meshes
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • Meshes to split with.
Returns:
Type: Mesh[]
An array of mesh segments representing the split result.
Available since:
5.0

Description:

Split a mesh with another mesh. Suggestion: upgrade to overload with tolerance.

Syntax:
public Mesh[] Split(
Mesh mesh
)
Parameters:
  • mesh
  • Type: Mesh
  • Mesh to split with.
Returns:
Type: Mesh[]
An array of mesh segments representing the split result.
Available since:
5.0

Description:

Split a mesh by an infinite plane.

Syntax:
public Mesh[] Split(
Plane plane
)
Parameters:
  • plane
  • Type: Plane
  • The splitting plane.
Returns:
Type: Mesh[]
A new mesh array with the split result. This can be None if no result was found.
Available since:
5.0

Split method

Class:  Rhino.Geometry.Mesh

Nothing found