Description:

Set texture coordinates using given mapping and applying given transform. Set lazy to False to generate texture coordinates right away.

Syntax:
public void SetTextureCoordinates(
TextureMapping tm,
Transform xf,
bool lazy,
bool seamCheck
)
Parameters:
  • xf
  • Type: Transform
  • Transform to apply to the texture mapping
  • lazy
  • Type: bool
  • Whether to generate lazily (true) or right away (false)
  • seamCheck
  • Type: bool
  • If True then some mesh edges might be unwelded to better represent UV discontinuities in the texture mapping. This only happens for the following mappings: Box, Sphere, Cylinder
Returns:
Type: void
Available since:
7.0

Description:

Set texture coordinates using given mapping and applying given transform. Set lazy to False to generate texture coordinates right away.

Syntax:
public void SetTextureCoordinates(
TextureMapping tm,
Transform xf,
bool lazy
)
Parameters:
  • xf
  • Type: Transform
  • Transform to apply to the texture mapping
  • lazy
  • Type: bool
  • Whether to generate lazily (true) or right away (false)
Returns:
Type: void
Available since:
6.0

/
/
/
SetTextureCoordinates

SetTextureCoordinates method

Class:  Rhino.Geometry.Mesh

Nothing found